Home Forums Particles Support Offcanvas full width flip mode won’t slider proper

Viewing 5 posts - 1 through 5 (of 5 total)
  • Sven-M. Wölfle
    Sven-M. Wölfle
    Subscriber

    When I set the Offcanvas particle’s width to 100vw (same with 1920px) everything works fine. If I turn the flipmode on it doesn’t slide in or out properly. It start to hop after a third of the way.

    This seems to be a problem of the UIKit-framework, I tried it also as an HTML-particle – same result.

    Worpress
    Helium and Balder

    Sven-M. Wölfle
    Sven-M. Wölfle
    Subscriber

    Just tried it in Grav width Helium with 1920px – there it hops in any mode.

    Avatar
    Tony
    Moderator

    Hi Sven,
    For this case, please open custom.scss file then add

    @media (min-width: 960px) {
        .jl-offcanvas-flip .jl-offcanvas-bar {
        right: -1920px;
    }
    }
    
    .jl-offcanvas-flip .jl-offcanvas-bar {
        left: auto;
        right: -1920px;
    }

    Let me know if it works for you

    Sven-M. Wölfle
    Sven-M. Wölfle
    Subscriber

    Hi Tony,

    Well, that works for me – thanks a lot!

    I changed it to -100vw so it would be cool to be able to choose between px, %, or vw in the plugin without hardcoding it.

    Avatar
    Tony
    Moderator

    Hi Sven,

    We will implement the theme offcanvas width settings for uikit soon.
    Thanks

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.